User avatar
By NinePoundHammer
#4899670
Hey all,

Been a while since I've been on the forums. So I just noticed that my Mattel PKE meters arms will not open anymore. When I press the buttons to open it there is a yellow light on the hilt of the meter that flashes and the arms do nothing. Has anyone else encountered this?

Thanks.
User avatar
By WindDrake
#4899686
The PKE uses three opto-interrupters to figure out where the arms are, which is why a PKE that's been turned off before it closed will cycle it's arms - it's trying to home them at the "Closed" position.

If the home opto isn't triggered on boot, the PKE won't move the arms.

Look for a broken wire.
By grogking
#4900160
Hard to tell from the image, but the red wire running to the outside edge near where the arms would be below the orange and yellow wires looks like it might have been crushed in one spot.
User avatar
By WindDrake
#4900676
Image

White circle - +Batt, could be crushed some but since your PKE powers up, it's probably fine.
Green Circle - Picture makes it look like the insulation is split - make sure this isn't the case.

Your optos are in here.

Image

If I remember right the white plastic part that connects the two arms together had something to do with it. I really should have documented the PKE better last time I took mine apart.
[SPOILERS] NEW GB MOVIE SUMMER 2020!

As long as towards the end when they're up against[…]

Oh, my expectations were set when I saw who was ha[…]

Car thermostat last I heard. Not sure if that's co[…]

Region 2 RGB Set Coming Soon

The German Blu-Ray set is getting re-released next[…]