By necrosapien87
So I took my trap apart to paint it, and today I put it back together and now it's not working quite right. WHen I turn it on, the red and yellow leds come on but when I hit the button for the doors, they open but the green leds and sound don't activate. Where di I go wrong?
User avatar
By jreverhart
Spirit trap?

Chances are you tugged a wire lose, they are not very secure, carefully take it apart again and check your wires you can use super glue to secure them as its not conductive just make sure to test it before gluing them.
TragicManner liked this
User avatar
By TragicManner
Yeah, if you're using a spirit trap, I think jreverhart is absolutely right. It would seem you have accidentally disconnected a wire. And I'm pretty sure I know which one.

In this video I did, I talk about the wire you probably disconnected here:

That green wire that goes to the gear assembly is, by default, an open circuit. In the circuit board for the spirit trap, it has several transistors that, when the green wire circuit is open, will not allow power to flow to the green LEDs. But as soon as the doors on the trap open, the circuit is closed, and the power is able to flow, but that circuit will only close if the two green wires that go to the switch on the gear assembly are properly soldered on.

Those two wires, by the way, are really poorly soldered on and it's not surprising one of them came loose. You just need to pop the trap back open and make sure they are soldered nicely in place. Use my video as reference if you need to, or if you have any questions just let me know.
jreverhart liked this
By JulesHiggs
I had a bad trap day today. After spending two days painting, screwing and all together making the trap look oh so nice... I got over zealous and, against my better judgement, popped the trap open to potentially add a rear connector for a hose...

Upon attempting to reassemble, two things have happened:

1.) All the lights operate just fine when the doors are open, but the sound no longer works. I did have a screw fall behind the circuit board where I had to retirieve it with my fingers and I'm wondering if I shorted it out somehow? Or maybe it's one of the green wires? Does once specific wire deal with the audio and one with the LEDs?

2.) The "clicked pen" functionality of the doors button is entirely compromised. It works SOMETIMES now, only after multiple pushes of varying strength. Sometimes not at all. Even when disassembled, and attempting to click it while holding the plastic mechanism in place, it isn't locking into place as it should (and as it did when first disassembled)

Any ideas?
User avatar
By TragicManner
Any luck on this? I'm guessing that it didn't turn out to be an issue with the wires somewhere coming loose?

The other thing that may have happened is one of the surface-mounted components on the circuit board may have come loose. Mind taking a picture of the circuit board and posting it? There are several transistors that, if they were damaged somehow, would explain why one system is working and another is not.

As for something getting shorted, that is totally possible. There isn't really one wire that drives audio/lights, the circuit board actually does a lot of this and so the problem is likely there if the wires going to the speaker look good.

I would pull apart the pen click system in the handle and make sure you got the small little components into the handle properly.


In that image you can see that the pen clicker is made up of the button, or cap, a white shaft with teeth at the end, and the mechanical inset that slots into the shaft that interacts with the teeth. The way those components are oriented in that picture are correct: If the tiny inset piece doesn't have the smaller portion inserted into the longer shaft, it won't work properly. Notice also that the cap screws into the shaft, and that, depending on how your trap turned out, having it screwed on too tight or too loosely can cause the pen mechanism to no longer function.

What is not pictured there is the actual head of the mechanism. This is the black thing that inserts into the opening at the end of the handle and actually pushes the tabs of the gate that controls the doors. When the button is pushed down, this is what is ultimately pushed down to close the doors. It needs to be seated properly into the opening on the handle to make sure it isn't out of reach of the pen clicker mechanism.

Finally, in the gear box that the door gears interface with, the springs on those tabs are what pushes the pen clicker assembly up when the doors open. If those springs are not on their pins, then the whole thing will stop working because nothing is putting tension on it all to keep the "pen clicker" working. Without the pressure from a spring, nothing interacts properly.

So, there are some thoughts. See if any of that helps figure out what may be going on, and if possible I would liketo see a picture of the underside of the circuit board with all the leads, transistors and resistors. Like this:

If that's too much to ask, then at least start with some of the other ideas and see if you can manage there. Also, when the screw dropped behind the circuit board, was the trap turned on?
By JulesHiggs
Thank you so much for the comprehensive response!

I believe I fixed the pen clicker issue. It was an issue of the cap being too tight/loose and adjusting that seems to help immensely. Still not 100%, but a much higher success rate right now.

As for the sound, still not luck. The screw that fell behind the circuit board was a metal cosmetic screw that I was added that fell into the body while being added. I don't recall if the trap was on, but I do remember the batteries were still in - so it may have been on at some point? Hard to say. It did fall directly behind the circuit board (green side).

Here are the photos of the circuit board, as well as the wire connections for the important parts (speakers, spring, etc). Hoping it enlightnes you, as the audio still isn't functioning and Halloween approaches :(

User avatar
By TragicManner
So, it's a long shot, and unlikely to be the problem, but you can check the transistor. Testing if transistor Q1 is bad, as that is the one I BELIEVE is switching on and off the audio stuff, might give you a clue. Unfortunately, the audio is a bit of a black box on this circuit board, and the chip driving it, and the chip amplifying the audio, seem to be hidden away under the black dot. But I believe Q1 would be the transistor to check. As I understand it, you can test a transistor just by checking continuity between the different pins, but it's not something I have done before so you will want to look up online just how that is done.

But again, that is a bit of a long shot, because I really doubt the transistor is bad. If something shorted, the transistor is probably fine, and the problem is because one of the chips driving the audio was damaged. So, unfortunately, it's most likely that your circuit board is basically dead to you now. But, you know, ruling out the transistor is probably the only thing you can do at this point other than what you've already done, so that might be worth it just to really exhaust all your options.

At any rate, hit me up with a PM and, if worse comes to worse, let's see if we can get you a new circuit board before Halloween.
By JulesHiggs
Hey there! I realized in all the Halloween hullabaloo, I never got back to you. Thank you for all your attempts at helping, but the trap remains broken (audio wise). I don't have a way to test the transistor available, unfortunately. I have read something about the speakers being sensitive and frying, potentially? Wish I knew how to swap out the speaker and try that. Either way, appreciate your help on this! Halloween still went wonderfully!
Who’s selling blower parts in 2020?

I’m considering doing a build but after look[…]

I've only seen the 4 GB on the pegs at smaller Wal[…]

Fincher makes legris elbows? That's the first I've[…]

[quote=timeware post_id=4935404 time=<a href=&[…]