By jinxed
#4925006
So I am nearly finished with my Spirit pack mod, and have encountered what seems like a battery issue to get it up and running. Not the most electrically savvy, I'm hoping someone here might be able shed some light.

I installed all 3 of the Spongeface kits (which are absolutely amazing) and have removed all the original electronics.
Sound blaster, wand kit, pack light kit. Nothing else.
Used a blue brick 12v 9800 mAh battery from ebay

Whats happening:
I charged the battery for 3 days with the switch on, uninterrupted. When I plug it into the pack, the pack lights work in what I believe are an idle mode, but zero sound, and no response from the switches or button.

Thinking I hadn't charged it enough, I plugged it back into the charger. Out of curiosity, I tried turning on the pack while it was charging, and it worked perfectly. All the lights, sounds, functions doing what they should. OK, the battery just needs more juice. So I left it charging another day unplugged from the pack. Still no go. So I contacted the seller on the battery, and they quickly sent me a new one figuring I got a dud. Went through the same exact process with the new battery, with the same exact results. Then I discovered something odd. If I have the battery plugged into the charger, I can turn the pack on with full function, and it will keep working even if I unplug it. But if I turn it off, it will not restart without being plugged in.

I have since tried leaving both batteries charge for over 4 days, not plugged into the pack, with power switches on. I installed an inline power switch between the battery and electronics. Tried adjusting volume all the way low before start up. Nothing makes any difference. I get the cyclotron lights, and the powercell light. No sound, no function from buttons.

Only thing I can figure is there is just not enough power to "start" the pack.
My questions:
Are my ebay blue bricks junk? Is the GB Fans brick of the exact same specs/shape/picture somehow different?
Is there a different battery I should consider?
Is there some other reason for the need to "jump start" my system?

Thank you for any points in the right direction. Very stumped.
Brad
By djmarz78
#4925019
first you shouldnt turn on the power while charging that could fry your electronics
you might have a loose connection somewhere start with that
make sure everything is plug correctly
also my first charge for the blue brick took a day and a half to fully charge
By jinxed
#4925021
Thanks for the heads up. No more turning on while connected to charger.

I've gone through the connections several times. Even bypassed my in-line switch to be sure that wasnt the problem.
Since everything functioned correctly when plugged in to the charger, I can only assume the connections on the electronics are correct. There's not really too many to make between the kits that arent pin connectors. Pigtail to sound board, sound board to speaker. All the other ribbon connections are fully seated.

I decided to use this as an excuse to pick up a multimeter. Don't know exactly what to make of the readings. More confused than not, that's for sure.

As for the charging, I've tried both batteries for up to 4 days on the charger. Lights are switching from red to green.
By Calidrifter
#4926217
I had a no sound or lights issue at first. It had to do with the volume control. It was easily solved by switching on the pack then adding the volume. Switching off and once switched back on it worked fine.

Also did you remove the tape from the power switch on the battery? I charged mine over night with it on and didnt get any juice. Once removed it took only a few hours to charge.
User avatar
By signeddiamond
#4926220
That’s not exactly what I’m talking about here. As an update I cracked my pack open and inspected everything. The battery had swelled slightly and indicated on the main board with only a faint red light. I have another battery I picked up to run a smoker and hooked it it. Instantly the board indicator light went bright red and the pack powered up instantly. Seems the battery was a dud with low output. I contacted the seller requesting a replacement.
By jinxed
#4926374
Just saw the replies and additional questions. Well, I did solve it, but kind of accidentally.

The multimeter was showing correct output on both batteries, so I went forward connecting everything individually one by one to chase down the issue. Each of the three systems would work individually, but not connected in the sequence I had them. What ended up working was connecting the battery leads to the pack light board instead of the sound board. A couple emails to Doug confirmed it would not cause any problems provided the battery leads were connected properly, and so I ran with it. Everything is working great, and the battery seems to plug away for a good amount of time.

I have to make a huge plug for the Ghostlabs kits. I was so impressed with them and the customer service. Really one of the best experiences I've had with something like this.

Hope you sort out your issue.

My money is on Saturday. How much? I'm down […]

Hasbro Ghostbusters

It seems Ghostbusters News removed their post...[…]

Flight suit by Mechanized

You sure put a lot of effort in creating the set )[…]

As a side note, I’d been slightly grumpy ab[…]