Page 25 of 25

Re: GBFans Shop Feedback

PostPosted:June 22nd, 2018, 8:05 pm
by Dr. Kyle Stevens
Just got my new name tag in today. Thank you so much, it really came out great! A+++

Clippards

PostPosted:July 13th, 2018, 5:01 pm
by dfak2009
My order for two clippard valves arrived fast and they are awesome! !

Thanks to AJ for his great communication and prompt dispatch of my order.

Thanks again
Hope to do business again soon

Re: GBFans Shop Feedback

PostPosted:September 19th, 2018, 10:38 am
by tobins78
Ordered my gun/pack lights and sound on September 5th and got them on September 19th in Birmingham, UK!

It'll take me longer to finish my wand and install them!

Re: GBFans Shop Feedback

PostPosted:September 19th, 2018, 11:28 pm
by twmedford23
I got my heatsink and banjo replicas in a short while ago. Well worth the wait!

Re: GBFans Shop Feedback

PostPosted:February 27th, 2019, 5:02 am
by LeBloop
This place is a one of my favourite shop for props part BUT there is a big lack of serious in business terms.
I put an order for team mate and me with only "in stock" items on Jan.19 and the estimated shipping date don't stop to change for the next work day...
Major problem with gbfans shop is you can't have an accurate shipping date, I purchased a set of aluminum parts, some was in stock and shipped the next following days, but the "special order" other parts was supposed to be shipped today and now it's estimated to March 27! WTF
The second problem is the communication, it's non-existent. And I know it's common according to several customers.

AJ if you read those lines, please can you take a look to my orders? (orders (36148 and 36149) Thanks

Re: GBFans Shop Feedback

PostPosted:February 27th, 2019, 12:09 pm
by Kingpin
Major problem with gbfans shop is you can't have an accurate shipping date
Unfortunately due to the nature of some of the items that are stocked by the shop, exact shipping dates aren't possible to give - which is why there are the rolling shipping estimates.

Re: GBFans Shop Feedback

PostPosted:February 27th, 2019, 12:42 pm
by AJ Quick
AJ if you read those lines, please can you take a look to my orders? (orders (36148 and 36149) Thanks
Yes. On one of the orders we are looking for a missing item. You ordered the very last one we have, and its a rare item that hasn't been produced for several years. As I wrote in an email to you, it will be located or it will be refunded and your order will ship minus that item.

On your other order, you have special order items that we rely on other people to provide to us. We are currently waiting on them for those items. That's why you have an updated ship date for them.

I believe we provide ship dates that are updated every day that you can reference. I don't proactively send messages to customers every day to inform of shipping estimates as that would cut down on the number of orders I am actually able to ship.

Re: GBFans Shop Feedback

PostPosted:February 28th, 2019, 4:25 am
by LeBloop
Thanks guys.
Obviously I know it's a human scale business, so I understand a lot of issues.

I've reply to the email ;)

Thanks

Re: GBFans Shop Feedback

PostPosted:June 27th, 2019, 8:08 pm
by RedSpecial
I recently ordered a wand light kit from the shop.

Shipping was fast, it was very well packaged and the functionality is second to none.
I can't wait to install it in my thrower once its finished.

The one small issue I had with the kit is that the LED with black and white wires which lights the hatlight on top of the body doesn't seem to be working.
Although I can live with it since this light doesn't seem to be functional in the movie.

All in all, I'm extremely pleased with this kit though.
I'll definitely be placing another order ASAP for the sound and pack light boards.

Re: GBFans Shop Feedback

PostPosted:June 28th, 2019, 5:15 pm
by RedSpecial
Just wanted to correct my previous post. Regarding the LED under the hatlight on the top of the thrower not working.
I've since discovered that it doesn't light up in movie mode, but acts as a venting indicator if you have movie mode with venting effects enabled.

So it wasn't a fault with the kit, but user error on my part.