User avatar
By BlueChainsawMan
#4910687
ok thanks, looks like just a shipping label was created.
Awesome...when did you originally order?
User avatar
By BlueChainsawMan
#4910700
Mine just shipped. Ordered two years ago.
I got word a little bit ago that delivery is estimated for 11/16Image
By Marcus B
#4910708
Ordered 11/17/17, shipped 11/13/18!

Is this everything I need to light it up and add sound? Do I need the sound programming board (which is out of stock..)?
Image
User avatar
By JWils23
Supporting Member
#4910716
Ordered 11/17/17, shipped 11/13/18!

Is this everything I need to light it up and add sound? Do I need the sound programming board (which is out of stock..)?
Image
That’s everything you’ll need! I’m running the same setup with no issues, I didn’t order the sound programming board.
By Marcus B
#4910717
I noticed on the amp it says the sounds are on an SD card now, so maybe that was for older versions.

The shipping is a bit steep though. It says it'd be $85 to ship in the US when I check out, but it's only $40 when I clicked for an estimate. I sent an email to webmaster@gbfans.com.
By livewire008
#4910758
Glad to hear packs are shipping for so many.

Ordered Oct 2016. Just got an email yesterday about remitting payment for shipping, which I did.

Waiting on any shipment info...
Marcus B liked this
By Marcus B
#4910761
They are actually listed as *IN STOCK* on the site. If the cost increase + quality concerns don't bug you, now is the time to get one.
By Sailerm
#4910774
I got the two packs I ordered months ago but was impatient and cancelled the Alice frame from them and ordered the frames from Amazon. I don't regret it. I got light kits from gbfans I'll
Eventually upgrade to sound as well. ImageImage
deadderek liked this
By Marcus B
#4910785
Ordered my light and sound kit last night. Too bad the power cell and cyclotron lights won't arrive until March.

I splurged and got the two real clippards as well.
By Marcus B
#4910865
Received the kit today. Pretty bummed though, it has a few broken parts and one bag of hardware is very corroded.
User avatar
By da_rambler20
#4910866
I got mine today as well and had 3 broken pieces. Already emailed them for replacements.

Have they updated their instructions yet or are they still the ones that are not very detailed?

Any updates on the video detailing the construction?

What’s a good glue to put this together with?

Thanks in advance for any answers!!!!
User avatar
By BlueChainsawMan
#4910868
I haven't looked through everything yet, but the bag of hardware was very dusty looking, so most likely corrosion.

I do have the proof of life here... ImageImageImage
User avatar
By echo419
#4910869
Looks likes it’s tough to cut through the power cell area, think I’ll put a strip of NeoPixels there instead.
User avatar
By da_rambler20
#4910870
The motherboard also will need to be cut down more exact as well. I may use something else for the MB
By venkman71
#4910874
For glue I would recommend epoxy or gorilla glue. Drill and tap everything else you can, ESPECIALLY the aluminum Clippard caps.
User avatar
By deadderek
#4910876
I got mine today as well and had 3 broken pieces. Already emailed them for replacements.

Have they updated their instructions yet or are they still the ones that are not very detailed?

They have not updated them at all.

Any updates on the video detailing the construction?

Nope. Likely never happening.

What’s a good glue to put this together with?

Not sure check out the Anovos build threads. :)

Thanks in advance for any answers!!!!
By Marcus B
#4910890
I got mine today as well and had 3 broken pieces. Already emailed them for replacements.

What parts were busted on yours? Mine was the thrower main body and the PPD.

The thrower body broke in an odd place, where the front handle attaches . Maybe missing a jagged 1/2 inch or so around the whole thing. The pieces were not in the wrapping or box.. so this happened before my kit was put together to be shipped. Guess they thought they could get away with shipping it to me like that.

The PPD only had one of the attached screws separate. I could probably fix it.. but I feel like they should take care of it before I muddle around with trying to fix it up. I bought a kit for a reason: easier to assemble.

In addition, a bag of hardware showed up looking like it's been on the Titanic since 1912. OK, that's a bit of an exaggeration, but several things are corroded quite a bit and it shouldn't be that way.
User avatar
By mike_waclo
Supporting Member
#4910891
I'll throw in some more tip to new recipients of the kit, as I've just started going through it with the kit I received a year ago...

  1. Get a good diamond-tipped Dremel bit to carve out the area around the powercell lights... This is a gloppy mess of fiberglass on the inside, and will take some serious cutting and grinding down.
  2. When you get to the wand, the handle pipe on the inside of the box is capped! This will need to be Dremeled open to run your pack ribbon cable through... Do this before mounting and gluing in all of your electronics. I learned that one too late.
  • 1
  • 5
  • 6
  • 7
  • 8
  • 9
  • 10

Watching the TRAILER again, and I swear, the m[…]

Yea I had a friend import one from Japan for me ha[…]

Just beat it again on switch "We gods for br[…]

ANOVOS Pack?

I would kill for instructions too for this damn pa[…]