#4950699
Check line 54

// LED indexes into the neopixel powerstick chain for the cyclotron. Each stick has 8 neopixels for a total of
// 16 with an index starting at 0. These offsets are because my powercell window only shows 13 leds. If you can show more
// change the offset index and powercell count to get more or less lit.
const int powercellLedCount = 14; // total number of led's in the animation
const int powercellIndexOffset = 1; // first led offset into the led chain for the animation

My pack I had to set offsets to turn off the first and last leds as they didn't fit in the space.
#4951895
The most likely situation is that the arduino is not communicating with the sx-1509. Make sure you have the 3v out from the arduino wired up properly to it. The full code with bar graph does a check to make sure the sx-1509 is communicating properly before continuing on. It's on line 169 of the code
Code: Select all
    // Call io.begin(<address>) to initialize the SX1509. If it
  // successfully communicates, it'll return 1.
  if (!io.begin(SX1509_ADDRESS)) {
    while (1) ; // If we fail to communicate, loop forever for now but it would be nice to warn the user somehow
  }
That is where I would start looking
#4951998
Nearly there now thank you for your help. Can o just ask you a simple thing that I can't seem to figure out but I'm sure it's so obvious.
How did you fix the neopixel jewel to the wand end with the acrylic tube? Was going to go pop and twist but I can't see how this would work with the size of the jewel.
Thank you and all the best.
  • 1
  • 17
  • 18
  • 19
  • 20
  • 21

https://i.ibb.co/nPpSqKq/Screen-Shot-2021-07-2[…]

I've positively I.D.ed the tires/wheels on the new[…]

Some of you may remember my previous build thread […]

I was tinkering around on Instagram today and saw […]