By Scottyk
#4974708
I purchased a light kit and sound board back in 2021. Just now getting everything together, and the sound board works fine independently, but I can’t get any response from the light kit.

If I power through the battery terminal, I can read voltage with a multimeter, but absolutely nothing happens. Same if I supply power from the ribbon cable. Just nothing. Even in “test” mode.

Is my kit DOA ? I know a bit about probing for power and continuity, but beyond that, this board is so dense, I don’t even know where to start looking for issues.
By Scottyk
By Scottyk
#4974726
Something is certainly amiss. On it’s own, The board responds properly in the test mode if I supply power to the auxiliary power terminals, not the main terminal.

When I hook the light board up to the sound board via the ribbon cable, all of the switches and buttons work - they activate the sound, but there are no lights. I did trace power coming to the board through the ribbon cable, but no lights… again unless the light board is disconnected and powered from the aux terminal.
By Scottyk
#4974728
It gets better. When I power the sound board by itself, then plug in the ribbon cable to the wand, the buttons and switches work properly… but still no lights.

Power everything down. Supply power again, and none of the buttons or switches work. I have to unplug the wand board, then recycle power to the sound board, then plug the wand board back in. Then it will work again (but still no lights)
    Proton Props UK

    You all keep uploading walltexts about patience an[…]

    Where to find vintage RGB figures??

    I’d love to get into collecting the packaged[…]

    DVD vs BluRay

    *hugs his 4k player, OLED tv, and Atmos setup*

    Spengler wand barrel sticking

    I returned it and got a new one (still orange tip)[…]